cf
continuous-integration/drone the build failed Details

pull/1/head
AAGaming 1 year ago
parent 758fe10a66
commit fc9bccf836

5
.gitignore vendored

@ -2,4 +2,7 @@
/node_modules/
yarn-error.log
.yarn
.svelte-kit
.svelte-kit
workers-site
build
functions

@ -2,14 +2,13 @@ pipeline:
build:
image: node:alpine
commands:
- apk add --no-cache rsync
- yarn
- yarn build-netlify
- yarn build
deploy:
image: ghcr.io/williamjacksn/netlify-cli
secrets: [ netlify_site_id, netlify_auth_token ]
image: mozmeao/wrangler
secrets: [ cf_api_token ]
commands:
- HOME=/home/node netlify deploy --site $NETLIFY_SITE_ID --auth $NETLIFY_AUTH_TOKEN --prod
- HOME=/home/node wrangler publish
branches: main

@ -1,4 +0,0 @@
[build]
command = "yarn build-netlify"
publish = "build"
functions = "functions"

@ -14,10 +14,10 @@
"svelte-media": "^0.1.4"
},
"devDependencies": {
"@sveltejs/adapter-netlify": "next",
"@sveltejs/adapter-cloudflare-workers": "next",
"@sveltejs/kit": "next",
"mdsvex": "^0.9.7",
"svelte": "^3.38.3",
"svelte-preprocess": "^4.7.4",
"mdsvex": "^0.9.7"
"svelte-preprocess": "^4.7.4"
}
}
}

@ -2,7 +2,7 @@
import { mdsvex } from "mdsvex";
import mdsvexConfig from "./mdsvex.config.js";
// import preprocessor from 'svelte-preprocess';
import netlify from '@sveltejs/adapter-netlify';
import workers from '@sveltejs/adapter-cloudflare-workers';
/** @type {import('@sveltejs/kit').Config} */
const config = {
"extensions": [".svelte", ...mdsvexConfig.extensions],
@ -14,7 +14,7 @@ const config = {
extensions: ['.svelte', '.svx', '.md'],
kit: {
adapter: netlify(),
adapter: workers(),
amp: false,
appDir: '_app',
files: {

@ -0,0 +1,9 @@
name = "aa-site"
type = 'webpack'
account_id = 'c81976a366cce65020294a3521c86590'
route = 'aa.catvibers.me/*'
zone_id = '55bd4d6eb6dbcd9819d50a56281e2f8d'
usage_model = ''
workers_dev = false
target_type = "webpack"
site = {bucket = "./build",entry-point = "./workers-site"}

@ -27,10 +27,10 @@
estree-walker "^2.0.1"
picomatch "^2.2.2"
"@sveltejs/adapter-netlify@next":
version "1.0.0-next.22"
resolved "https://registry.yarnpkg.com/@sveltejs/adapter-netlify/-/adapter-netlify-1.0.0-next.22.tgz#69c2e63a3534dbbbc99905fb29b4dd77a7f51fd4"
integrity sha512-YN4qCT3rQQl+KLJjUHeQ30YBhfeIGDx1KwStVg+el9ii+owwiBj006A3qgumq7lldtm6ORnBO2BtBvua6MWYJg==
"@sveltejs/adapter-cloudflare-workers@next":
version "1.0.0-next.15"
resolved "https://registry.yarnpkg.com/@sveltejs/adapter-cloudflare-workers/-/adapter-cloudflare-workers-1.0.0-next.15.tgz#fbe16bdb52c75e72cb41372a453d0e52cf2fd51d"
integrity sha512-8qUrKvzbTTwSfK4deIIKKCbLesSwMi78BMbWuyGPcEAq58dhKMhsoHqrHNOoJXnQWPK+CCkgSRJp5sCZLXdxcg==
dependencies:
"@iarna/toml" "^2.2.5"
esbuild "^0.12.5"

Loading…
Cancel
Save